Home Forums Pro Themes Bizlight Pro Main Nav Active Hover Color

Tagged: ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1681
    Anthony
    Participant

    Sorry need a little more css help. Want to select the active submenu.

    For example menus currently highlight red, but then when moving down the sub-menu to the 2nd child, the 1st sub-menu child changes color.

    #1683
    Anthony
    Participant

    Also I see this was built on bootstrap. I am new to wordpress and was wondering if when I edit a “page” in the wordpress panel, can I hard code bootstrap divs and functionality? Or where would I put this?

    #1694
    wensolutions
    Keymaster

    Hello @Anthony,
    For fist question: we would request you to please post your site-url.

    For second question regarding changes: The best way to make changes like this to a theme is to use a child theme, so your tweaks won’t be overwritten when updating the theme. Here are some guides in case you haven’t made one before:

    https://codex.wordpress.org/Child_Themes

    I hope this helps resolve your issue.
    Regards.

    #1707
    Anthony
    Participant

    Hello Mr. Support team. The site temp URL http://66.147.244.96/~bridgga7/

    I guess where I was going with the editing, is you’re already including the JS and CSS files for bootstrap to each page. When I am editing the page, can I type up bootstrap divs and will that simply suffice and still be okay to update, assuming you don’t update the actualy bootstrap version.

    #1708
    Anthony
    Participant

    Nevermind Created the child theme. 🙂

    #1722
    wensolutions
    Keymaster

    Hello @ Anthony,
    For menu hover, you can paste the following code in your child theme’s style.css or in Custom CSS section.

    .main-navigation ul ul{
    background-color:#F40000 !important;
    }
    .main-navigation ul ul ul{
    background-color:#F40000  !important;
    }

    This should change the main nav active hover color.

    And for customization, you can customize in your child theme. Now even if new version of the theme is released then it won’t effect the customization that you have made in your child theme.

    Regards.

    #1741
    Anthony
    Participant

    Hey thanks for the reply again. Another minor issue now witht he child theme. I’ve created the child theme, the only thing I’ve put in it is the functions.php and style.css file. the link is above and you can see what the mobile menu is doing now. Any tips would be much appreciated.

    <?php
    add_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’ );
    function theme_enqueue_styles() {
    wp_enqueue_style( ‘bizlight-pro’, get_template_directory_uri() . ‘/style.css’ );
    }
    ?>

    #1761
    wensolutions
    Keymaster

    Hello @Anthony,
    Try this code inside child theme’s functions.php only:

    
    <?php
    add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles');
    function theme_enqueue_styles() {
        wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );
       }

    And your child theme’s style.css goes something like this:

    
    /*
    Theme Name:     Bizlight Pro child
    Description:    Bizlight Pro child theme
    Author:         admin
    Template:       bizlight-pro
    
    (optional values you can add: Theme URI, Author URI, Version, License, License URI, Tags, Text Domain)
    */

    Let us know how it works.
    Regards.

    #1763
    Anthony
    Participant

    Still the same thing unfortunately

    #1764
    wensolutions
    Keymaster

    It was found that CSS are getting overriden by your child theme style.css where you have added ‘foundation css ‘. As a result, menu in responsive was messed up.

    You can correct it by adding the following line of CSS code

    @media only screen and (min-device-width : 320px) and (max-device-width : 640px) {
    .main-navigation li {
      
       display: block !important;
       width: 100% !important;
    }}

    You may consider disabling current Mega Menu to try the above CSS in previous state.

    Hope this helps

    #1783
    Anthony
    Participant

    Thank you for all of yoru replies. I got the menu to work out. I ended up using the wrong foundation file. I was only using it for a couple components and didn’t put the gutted version in the directory. 🙂 So Thank you for that.

    Gave up on mega menu, looked cool but didn’t work properly.

    Have another question for you too unfortunately. Trying to take away the text-decoration of all of the links on the homepage for hover. The navigation menu as well as the services section. Thank you again!!! You guys have been great.

    #1797
    Anthony
    Participant

    That and I think one of the last things is making the submenus open to the right of the main nav instead of the left. 🙂 Thank you so much for all of your reply guys, and providing this theme. 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.