Home Forums Pro Themes Bizlight Pro Navigation Menu

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3901
    Anthony
    Participant

    Hello,

    http://66.147.244.96/~bridgga7/ is the temp site url. Was wondering the easiest way to go about changing the active and hover colors. Also if you look, any menu item with a 1st and 2nd child, automatically displays the second child when the first is hovered over. Thank you in advance!

    V/r,
    Anthony

    #3954
    wensolutions
    Keymaster

    Hi,

    For color change on hover paste the following CSS code

    #primary-menu li a:hover {
        background-color: #FF0000 !important;
    }

    For active menu color paste the following CSS code

    #primary-menu li.current_page_item > a{
    
    background-color: #FF0000 !important;
    }

    Hope this helps!

    #3985
    Anthony
    Participant

    Any advice on getting the child elements to only display on hover? For instance, the Systems&Solutions->Readers automatically displays the 3rd child element.

    #4008
    wensolutions
    Keymaster

    Hello @Anthony,
    We inspected your site and found that there were no third-level child on the menu. Anyways, we tried to replicate that issue on our end but it is working fine for us. That is, no issue on the third level as well.
    Let us know if you are still facing that sort of issue.

    Thanks,

    #4055
    Anthony
    Participant

    I removed the third level when I couldn’t solve the problem. It began after you guys gave me a fix for the child element opening to the left of the parent menu items instead of the right. I can put it back up if you’d like.

    #4078
    wensolutions
    Keymaster

    Hello @Anthony,
    Yes, you can put it back and let us trace the issue.

    Thanks,

    #4081
    wensolutions
    Keymaster

    Hello @Anthony,

    We have managed to replicate the scenario similar to your issue.
    As you have said It began after you guys gave me a fix for the child element opening to the left of the parent menu items instead of the right.
    In this thread you were given below custom CSS to add:

    
    .main-navigation ul ul li:hover  ul {
        left: 200px;
        width: 200px;
    }
    

    Now you need to remove these Custom CSS.
    After removing you need to add below CSS in child theme style.css file:

    
    .main-navigation ul ul li:hover > ul{
      left: auto;
      right: -200px;
      width: 200px;
    }
    

    Hope this will help to resolve your issue.
    Let us know how it goes.

    Best Regards!!

    #4180
    Anthony
    Participant

    Hey thanks for the response. I will give this a try, though I kind of found an organization where I didn’t require it anymore. Again, Thank you.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.